MT https suckiness

This event has been the first time, where i have been written some more blog entries over an insecure network since the MT4 upgrade. So this is the first time i noticed this problem with my blogsoftware.
I have been using https for the blog for some time. Unfortunately the new MT4 JavaScript^WAJAX navigation seems not to work if i access the admin frontend via https. I tried both Safari and Firefox.
If i rerequest the form with http everything works. I have no idea why.

MT 4.01

Today i finally started working on updating the MT port to the new major version. It was about time, because MT compared to its competitors lacks features.
Well everything seems to work well it seems, as you can read this post.
But of course the new version needs more RAM and is very slooow. And the new management web interface is just plain ugly.
If no major error shows up this week, i will commit the update this weekend.

MT4 available

MovableType 4 was released. Unfortunately i am a bit busy at the Moment. So i will most likely not have time to play with it before next week. Since this is a major update i would not expect a portupdate in less than two weeks.

MT StyleCatcher broken with Konqueror

It has been a while (several version updates) since i have been tinkering with the MT templates, my current stylesheet for this blog still fits well enough.
Today i created a new blog for testing, and noticed that the default stylesheet does not work with Konqueror anymore (It works okay in Safari).
Anyone got an idea why? I currently don’t have the time for stylesheet debugging, so for now i will stick with bloaty Firefox on FreeBSD. Hopefully KDE4 will fix this…

This Blog and IPv6

Unfortunately FreeBSD jails don’t yet support IPv6.
Because I wanted my site to be reachable from IPv6, I previously had a redirect on the AAAA arved.priv.at host redirecting to the IPv4 address of the jail.
But now i have finally configured a better solution, using the lighthttpd proxy module.


Snippet from the lighthttpd config:

server.modules              = (
"mod_proxy",
"mod_accesslog" )
server.use-ipv6 ="enable"
server.bind = "2001:6f8:13fb::1"
proxy.server    = ( "" =>
( "localhost" =>
(
"host" => "213.9.70.76",
"port" => 80
)
)
)

BTW, just in case you wondered, in the last year there have been nineteen unique IPv6 addresses from 5 networks (my netblock excluded) in the access.log. Most important one of the Planet FreeBSD aggregators is using IPv6.

test entry

Another test entry. MT now running at 3.32. Will commit port update after this post appears.
Only one port update left from my vacation….